Workflow task page shows an error on opening, but still opens

0
Hi all, When I click on a task in the task inbox, I get an error message saying 'Unable to execute action because you do not have sufficient permissions.' But then the task page opens and is fully functional. And in the console, I actually get 2 of the exact same error every time I open a workflow task, saying: Unable to execute action because you do not have sufficient permissions. Error: Unable to execute action because you do not have sufficient permissions.    at http://localhost:8080/mxclientsystem/mxui/mxui.js?638349701270311368:66:232517    at [compute] (http://localhost:8080/mxclientsystem/mxui/mxui.js?638349701270311368:66:170613)    at o (http://localhost:8080/mxclientsystem/mxui/mxui.js?638349701270311368:66:170418)    at v (http://localhost:8080/mxclientsystem/mxui/mxui.js?638349701270311368:66:169735)    at http://localhost:8080/mxclientsystem/mxui/mxui.js?638349701270311368:66:169356    at Array.map (<anonymous>)    at m (http://localhost:8080/mxclientsystem/mxui/mxui.js?638349701270311368:66:169254)    at http://localhost:8080/mxclientsystem/mxui/mxui.js?638349701270311368:66:168557    at Object.useMemo (http://localhost:8080/mxclientsystem/mxui/mxui.js?638349701270311368:34:69092)    at t.useMemo (http://localhost:8080/mxclientsystem/mxui/mxui.js?638349701270311368:54:6038)   Can someone please explain what this means and how to fix it? Thank you so much!
asked
1 answers
1

Solved:

 

In the end, I looked through all the permissions settings in the Workflow Commons module and added the ones that were off for admins (for me the issue was only for admins, I discovered after I posted). the one that was missing for me was the nanoflow DS_WorkflowUserTask_AssigneeHelper, and then I needed to enable entity access for admins for AssigneeHelper.

answered