Mendix cannot read XML file when trying to create a pluggable widget

Hi guys, so I am trying to create a pluggable widget (a text box) following the learning path for it. After adding some properties to the XML file, I ran the “npm run build” command and it didn’t give me any errors so I believe it ran successfully. Following that, I tried to synchronize the app directory in Mendix so that I can view the changes made to my widget. However, it gives a popup error saying that “some widget packages could not be read” and that the XML file that I made changes in could not be read. I have attached a screenshot of the error. If anyone knows how to fix this issue, pleas help!!  
1 answers

Unfortunately, the error does not say which element is in error. Could do with a more specific error here. When you get such a generic error it usually means there is a syntax error in the XML file. Tools like Visual Studio Code usually help you with that.

Could be as simple as a missing close tag. Also, each property must have a Description tag but you may leave the value empty.


Double check the XML file for syntax errors. I have had a very persistent one with a new widget I wanted to create. I ended up removing all properties except a simple one and adding them back in until I found the error. Also turned out to be a syntax error.