SVN lock error when downloading, use tortoise, but teamserver is then disabled

Hi there, I got the SVN lock error when trying to download a project from a team server. So I cleaned the folder up using tortoise SVN and then I can open it. Problem is that this is then a local project instead of teamserver project. Does someone know how to enable teamserver again and be able to select the right teamserver, not a new one. Or how to remove the lock before downloading the project? EDIT 31-08: Unfortunately this same error again. My teammates commiting a few times to the project didn't help. Tried creating a folder before downloading the project to it. No idea how to solve it without it solving itself :/ SharpSvn.SvnWorkingCopyLockException: Working copy '\\s1\main_10' locked. ---> SharpSvn.SvnWorkingCopyLockException: '\\s1\main_10' is already locked.    --- End of inner exception stack trace ---    at SharpSvn.SvnClientArgs.HandleResult(SvnClientContext client, SvnException error, Object targets)    at SharpSvn.SvnClient.CheckOut(SvnUriTarget url, String path, SvnCheckOutArgs args, SvnUpdateResult& result)    at SharpSvn.SvnClient.CheckOut(SvnUriTarget url, String path)    at Mendix.Modeler.VersionControl.SvnConnector.ClientDo[T](Func`2 action) in C:\jenkins\workspace\AppStudio3.0-Build@2\modeler\Mendix.Modeler.Core\VersionControl\SvnConnector.cs:line 54    at Mendix.Modeler.Utility.ActionUtil.TryNTimes[TException](Action action, Int32 n, Int32 sleepBetweenTries) in C:\jenkins\workspace\AppStudio3.0-Build@2\modeler\Mendix.Modeler.Utility\ActionUtil.cs:line 19    at Mendix.Modeler.VersionControl.SvnConnector.Checkout(Uri urlToCheckout, String targetProjectDirectory) in C:\jenkins\workspace\AppStudio3.0-Build@2\modeler\Mendix.Modeler.Core\VersionControl\SvnConnector.cs:line 168 Not connected to teamserver :/ though I did manage to download it so that's already a huge plus 
1 answers

I see that you are downloading the project to a network drive. Can you try and download it to someplace on your C: drive instead? 

The working copy gets locked if a Subversion operation fails halfway. To get rid of the lock you can use TortoiseSvn 1.7.15 and do a "Clean up" on the directory. However, the directory will still be in an akward state because of the failed operation.

If the initial download of the project fails, it may be the case that there is some kind of timeout. I recently saw a project with a node_modules directory inside with almost 10,000 files in it. That can cause a checkout to fail.