App will not run

0
I am creating an app with a barcode scan function. I have added the barcode scanner and I don’t have any errors, but every time I try to run in Studio Pro (9.11.1), I get the following error message:   Mendix.Modeler.M2EEConnector.M2EEException: The server encountered an error.    at Mendix.Modeler.M2EEConnector.M2EEResponse.CheckSuccess() in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\M2EEResponse.cs:line 57    at Mendix.Modeler.M2EEConnector.M2EEClient.UpdateAppContainerConfiguration(Int32 port, String listenAddresses) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\M2EEClient.cs:line 161    at Mendix.Modeler.M2EEConnector.StartupManager.PerformStartup(StartupInfo info, IM2EEClient client) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\StartupManager.cs:line 29    at Mendix.Modeler.M2EEConnector.RuntimeController.Start(StartupInfo info, LogLevel autoSubscribeLogLevel) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\RuntimeController.cs:line 135    at Mendix.Modeler.Deployment.Local.LocalRunner.<>c__DisplayClass70_1.<RuntimeLaunched>b__1() in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Deployment\Local\LocalRunner.cs:line 336    at Mendix.Modeler.Utility.BackgroundUtil.<>c__DisplayClass1_0`1.<Do>b__0(Object s, DoWorkEventArgs e) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Utility\BackgroundUtil.cs:line 29    at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)    at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)     Any thoughts?
asked
3 answers
0

Did it work Jeff?

answered
1

Hi Jeff,

Are you running something else on the same port?

If thats true, you can change your runtime port in the app settings. See the picture below for reference.

I hope this helps.

Kind regards,

Bob Boons

answered
1

Yes it did! I just randomly changed each port and it worked. I don’t know a lot about port configuring, so researching which port is safe to use. Thanks for pointing me in the right direction!

answered