Custom Save and Cancel buttons stop working when I change Object Access security!

Can anyone explain why this might be happening? I have a microflow which creates 3 different objects and then opens a form to edit just one of the objects. When the form is closed I want either to commit all 3 objects (if 'Save' is selected) or rollback all 3 objects (if Close has been selected). So I have created custom 'Save' and 'Cancel' buttons to perform the necessary processing. If the custom 'Cancel' button is pressed it calls a microflow which deletes the objects which were created above. When I first ran this I got a Mendix security error as I hadn't given the user role delete access on the necessary objects. So I updated the Object Access to allow delete access to the required use roles for the relevant objects, and now it doesn't work at all. The custom Save and Cancel buttons no longer respond, and neither do the defaul Save and Cancel buttons on the control bar. In fact the form hangs & I have to close my browser window & restart. The microflow which performs the delete and the objects which are being deleted are in different modules in the project file - could this have anything to do with it? Thanks. UPDATE * Yes - I have tried all of the suggestions below, and various other things, but there is no change. If I remove the delete permission on Object Access then the buttons work but I get the security error. When I add the delete permission on Object Access then the buttons stop working. UPDATE * This is running in Mendix 2.4.6 by the way.
2 answers

No the location of the microflows and objects shouldn't have any influence here. When starting the application, have you synchronized your model file? Were there any changes to the forms? And have you tried clearing your browser cache (ctrl-shift-delete to open the option screen for that in most browsers) and reloading all the pages, then logging back in?


I have tried to recreate your situation as best as I can and things work as expected here. Do you see error messages in the console dock when you press a button and nothing happens?