Trouble with renaming exposed attributes on published webservice

Hi all, I'm having some trouble changing the exposed names of my attributes in a new published webservice. As I received a WSDL file from the client with specifications I need to have an attribute with 'id' and an attribute with 'type'. As we all know, these are reserved and can't be used for entity attributes, but should be possible as exposed names in a webservice. So I go to my webservice > operation > return type > select exposed attributes and names and change the names. As this point all is well and i can immediately export a new WSDL where the element names are 'id' and 'type'. If after saving the operation and webservice, I open the operation again, I immediately get the following message and my exposed names are back to '_id' and '_type': But I haven't changed the domain model. I haven't changed anything. I have tried to create a new webservice and duplicate the settings but after saving and opening it fails again. I tried deploying and running in between. It should be possible if I check the documentation In fact, my exposed names change when I change my attribute names and if I'm correct, this should not be the case ( Is this a bug? Any help is appreciated!  
1 answers

Yes, this seems to be a bug. I can easily reproduce it:

1) Create an entity with 2 attributes
2) Create a microflow that returns the entity
3) Publish the microflow
4) Choose 'id' and 'type' as the exposed names of the attributes.
5) There are no consistency errors, but if you open the operation, it gives the popup that your screenshot shows

I think you should submit it as a support ticket.