Error when starting the database viewer

When I click advanced – start built-in database viewer, I got an error and I don't have a clue, any suggestions? (Studio Pro 8.11.0) Mendix.Modeler.M2EEConnector.M2EEException: Request <{"action":"start_hsqldb_gui","params":{}}> failed:  ---> System.Net.WebException: The request was aborted: The operation has timed out.    at System.Net.HttpWebRequest.GetResponse()    at Mendix.Modeler.M2EEConnector.M2EERequest.DoHttpRequest(String json, Int32 timeout) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\M2EERequest.cs:line 173    --- End of inner exception stack trace ---    at Mendix.Modeler.M2EEConnector.M2EERequest.DoHttpRequest(String json, Int32 timeout) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\M2EERequest.cs:line 186    at Mendix.Modeler.M2EEConnector.M2EERequest.Execute(Int32 timeout) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\M2EERequest.cs:line 69    at Mendix.Modeler.M2EEConnector.M2EEClient.StartHsqldbGui() in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\M2EEClient.cs:line 309    at Mendix.Modeler.M2EEConnector.RuntimeController.StartBuiltInDatabaseBrowser() in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\RuntimeController.cs:line 88    at Mendix.Modeler.UIFramework.Progress.ProcessRunner.RunStep(Step step) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.UIFramework\Progress\ProcessRunner.cs:line 83    at Mendix.Modeler.UIFramework.Progress.ProcessRunner.OnDoWork(Object sender, DoWorkEventArgs e) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.UIFramework\Progress\ProcessRunner.cs:line 63    at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)    at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
4 answers

Have you tried deleting the deployment folder and restart the server again.


Good tip from Hari. Would be my first response too.

For what it is worth: “Works on my machine”. This version of the HSQL databasemanager:


Did you application start up correctly, showing the message that the database was connected ok:

Database: HSQL Database Engine 2.5.0, name: 'default'
Driver: HSQL Database Engine Driver 2.5.0

Also, check if the HSQL database manager does function for your Mendix apps in other versions.

There is this hsql-jar installed along with installing Mendix 8.11:

If the HSQL db manager has yet never functioned in 8.11 on your laptop, maybe something went wrong during the installation of Mendix 8.11, you might remove it and install it again.


A colleague just had the same problem.

The cause of the error was, that another process already listening at port 9001 on the computer, which the HSQL database uses by default for connecting.

With the cmd command 'netstat -ao | find "9001"' or as admin 'netstat -aob | find "9001"' the running process can be displayed. In our case it was the PID 4 [System].

With the command 'netsh http show servicestate' we found the responsible program. 
The entry which we found was:
    Registered URLs:
                 HTTP: // +: 9001 / IGCC / SERVICE /

After the service 'Intel Graphic Command Center' (IGCC) has been deactivated in the task manager, the database viewer starts normally.


I have the same problem.
The application is working perfect however when I click on the database viewer i get the message and the server will not stop anymore. I get the option to force quit the server. This message i don't get when i start the server again and not click on the database viewer. 

Removing the deployment folder or reinstall of the mendix software 8.11.0 didn't solve the problem.

I hope somebody has a solution for it.