Learning Path: Rapid Developer 2018 - unexpected results with nested data

I've been following the learning path and everything seemed okay up to module 7.10.2. But when I tried to create a registration list to set the total number of registrations in the TrainingEvent object, things started to go awry: I couldn't get the registrations to add up.  When trying to solve this, I noticed that when I ran the app locally from the Desktop Modeler (7.17.2), the TrainingEvent Registrations Overview page didn't actually show any registrations. I added a new course and a new training event to make sure, but the same thing happened: when I used the "Add" button on the Registrations Overview page and saved a  new registration, it wasn't being added to the overview. I tried the same from the Web Modeler, and the Registrations Overview page was working correctly there. I tried synching the Desktop Modeler project with the Web Modeler, but that didn't make a difference.  So I decided to start afresh: I've upgraded the Desktop Modeler to 7.18.0 and imported a new project package (under the Resources tab in module 7.1). I haven't made any design changes yet to the app, either in the Desktop Modeler or in the Web Modeler. But after I've added sample data  the Registrations Overview page isn't showing any registrations at all, either when I run locally from the Desktop Modeler or when I do a preview from the Web Modeler.  What am I missing? Any insight is greatly appreciated :-)
2 answers

UPDATE: A small bug in the project package (the one that Mendix provides as a resource in module 7.1 of the Rapid Developer learning path), I think. 

The Add button on the Registration_Overview page does not have the TrainingEvent entity as a constraint (Registration_TrainingEvent/Registration), but uses the Registration entity instead. Hence, a new Registration object is not being associated to a  TrainingEvent object and is not shown on the TrainingEvent_Registration_Overview page.  

Changing the entity for the Add button on the Registration_Overview page from "Registration" to "Registration_TrainingEvent/Registration" solved it. 

Okay, that only took me half a day ... Now finally back to module 7.10.2  and trying to set the total number of registrations on the TrainingEvent_Overview page ;-)


Hello Anne,

I would first check if security is enabled, if it is I would try it with it disabled, second I would check if you have a commit action when you're saving the TrainingEvent objects (not needed if you're using the default save button).

Hope this helps