Issue with importing XML (Possible memory issue?)

I have a strange bug in my application (I'm thinking it is a memory problem but I am not sure). In my application I have several XML imports for rather large files (a lot of lines, not large in MB's). If I run my application locally (on a rather fast computer) i have no problems with importing these XML files. However, in the cloudnode for our customer, whenever I import one of these XML files, (which needs to be done on a daily basis) it starts loading and after a while i receive an error ("' Contact your system administrator''). I'm not sure where I can look into this error, I have tried looking into it with firebug, but all I seem to find is a ''Timeout'' I think, but I'm not even sure if that applies to the specific action I am doing. However, it does seem to import all of the lines in the XML, which is the strange part. When these imports are done manually this is not a big problem (allthough strange, and not sure if it has any implications on the actual import). But the plan is to make these imports automatically which might introduce some problems if it starts producing error messages. I've tried working this out via the forum but I can't seem to figure out what the problem is. Any help is majorly appreciated!
1 answers

Are you importing the XML synchronously, by any chance? See this blog article for details.