Dumpdb fails on server

Hi, We've recently deployed our new app on a on-premise Linux server. I tried creating a dump of the Postgress database (located on a different server, but correctly configured in the yaml file) When every application we try this with, succeeds, this one fails, with the following message: INFO: Writing database dump to /home/mendix/smt_acp/data/database/smt_acp_20140724_134633.backup Traceback (most recent call last): File "/usr/bin/m2ee", line 1055, in <module> cli.cmdloop() File "/usr/lib/python2.7/cmd.py", line 142, in cmdloop stop = self.onecmd(line) File "/usr/lib/python2.7/cmd.py", line 221, in onecmd return func(arg) File "/usr/bin/m2ee", line 624, in do_dumpdb pgutil.dumpdb(self.m2ee.config) File "/usr/lib/python2.7/dist-packages/m2ee/pgutil.py", line 30, in dumpdb proc = subprocess.Popen(cmd, env=env, stdout=open(db_dump_file_name, 'w+')) File "/usr/lib/python2.7/subprocess.py", line 679, in __init__ errread, errwrite) File "/usr/lib/python2.7/subprocess.py", line 1249, in _execute_child raise child_exception OSError: [Errno 2] No such file or directory I suspect we're missing a library of sorts, but which one, and how do I get it? I tried looking for the different .py files on the Linux machine, and they seem to exist... Thanks in advance!
3 answers
OSError: [Errno 2] No such file or directory

Would imply that either /home/mendix/smt_acp/data/database/ or the pg_dump command doesn't exist. Can you confirm the existence of both?



Thanks for your response. I looked at that too, and did the following:

smt_acp@vmapp075:~$ ls /home/mendix/smt_acp/data
database  files  model-upload  tmp

At this point I figured everything was ok, since it lists the 'database' folder.

When I use WinSCP:

alt text

Any tips? (The folder database DOES contain data)

I'm looking for the pg_dump file as we speak, but notice that the command psql gives the same error.

I spoke with the database-guru of our customer, he gave me the following (sent from the seperate database server):

root@vmapp076:~# pg_dump
pg_dump: [archiver (db)] connection to database "root" failed: FATAL:  no pg_hba.conf entry for host "[local]", user "root", database "root", SSL off

He's checking the config file for more info. Any tips are still welcome ofcourse :)


We were indeed missing a file. The Mendix application server missed a postgres-client-package. After installing that one, everything works fine now

Thanks for the nudge in the right direction Achiel!