MxModelreflection does not show all references

I am totally mistified by this one so I hope somebody can give me a clue about what goes wrong here. We use the MxModelreflection in combination with the email token replacer. We needed a new token so I created a new reference to handle the token. But the reference is not shown in the MxModelreflection. I even deleted all objects and created the table from scratch but the new reference does not show up while the old ones do. I then started to delve a bit deeper to check some other references and to me it looks like random references are not shown. Here are some screenshots to make my point clear. Entity TokenObjectPrint Now the screenshot from the model reflection Entity Taak Modelreflection Taak Entity BankGiro Modelreflection BankGiro I fail to grasp the differences between these objects. Why are all the references shown in BankGiro, am I missing the new reference in TokenObjectPrint and are no references shown of entity Taak? Why are there some references missing? Is this a bug? We use V3.3 from the model reflection the last one for Mx4. Regards, Ronald
2 answers

Check the access rules on the missing reference. Do you have read access when you login?


We found the sollution (after quite some time) and I am still not sure if it is a bug or as by designed. We also had a module with an entity whose parent was Taak. And since this module was not selected as a module to synchronize in the MxModelreflection the parent is also not synchronized.

I am still not sure if I find this a bug. I would have found it logical it would synchronize all the references of Taak and skip the references to modules that should not be synchronised. Now it just skips all the references.