Project created with Mendix 5 layout and App Store modules

When importing App Store modules I get several errors. The project has been created using Mendix 5.0.0 and converted to 5.1.1 CommunityCommons and DeepLink get errors about persistent create actions which have been deprecated. These can be converted so that has not been a real problem. DeepLink, MxModelReflection and EmailTemplate have problems with the layouts. I tried fixing these but it proves a challenge as some pages are actually popups while they refer to a non-existing layout named DesktopLayout. And MxModelReflection brings in it's own layouts, which get errors too. I created a fresh 5.1.1 project and then everything is just fine: the modules can be imported without errors. I noticed that the layouts module and the default MyFirstModule are different: they have no folders. Edit: I must have made an error here as the project has the default layout. I then created another 5.1.1 with Mendix 5 layout. The layouts project and the default MyFirstModule have subfolders: Desktop, Tablet and Phone. My other projects, all created using Mendix 5.0.0, have a layouts module with the sub folders mentioned above. I even tried exporting the layouts module with no folders and importing it into my other project but then the Administration module gave errors too. So now I am a little confused about what to fix. It seems that the projects that were created with <edit> Mendix 5 layout are way off standard, which makes importing (and updating!) app store modules really difficult. Edit: it has nothing to do with Team server enablement, but the Mendix 5 layout brings in the folders in the layout module. The blank layout does not. I am not sure whether this goes against forum policies here but I removed the incorrect parts of my original post. I suppose I need to bring my projects to the blank layout if I want to use the App Store modules.
0 answers