ExcelImporter Template

Hi everyone!  In my app I am using the ExcelImporter Module. My app is supposed to import an excel file and open it in one specific page, like a catalog but whenever I have new data, I upload the new file and every user can see it in the app. I tested it one time and everything worked fine, I imported the file and I was able to see the data (of the file in the app) but now, when I try to upload a new file I can’t, my log message says that there is not a template even though I have a one. I really don’t know what I am doing wrong, I tried to do everything as I did the first time I tested it but it didn’t work; I deleted the template, uploaded a new one, and try to upload my new file but still doesn’t work.  Sorry if this is a dumb question but I do not know how to solve it.  Here’s the message I get, but I do not have more info of the error since there’s no stack trace.   
2 answers

HI kenya,


First you can debug your microflow IVK_ImportTemplateDocument to check if  the retrieve of Template is not empty.

If this is empty, please check what is in your parameter TemplateDocument.

If the parameter TemplateDocument is also empty, you need to check where this information is coming from and where you can select the TemplateDocument.


Also you can find more information on the Excel Importer in Mendix Docs





The message ‘Something went wrong...’ is probably triggered from the StartImportByTemplate java action in the microflow IVK_ImportTemplateDocument. To find the cause of the problem, you might take a look at the more detailed error message in the Console logging (the console pane in the modeler, if you are testing locally).


If this doesn’t work, you could try to eliminate all the excel import configuration you don’t need. Maybe to start from scratch to find out the it ‘went wrong’.