Change the Java version used to compile apps locally

1
Hi, I receive the below UnsupportedClassVersionError when trying to run my application in Eclipse using Java 1.8.0.241: Exception in thread "main" java.lang.UnsupportedClassVersionError: system/UserActionsRegistrar has been compiled by a more recent version of the Java Runtime (class file version 57.0), this version of the Java Runtime only recognizes class file versions up to 52.0 Java 13 supports class file version 57.0, so I switched the build path to use Java 13. But then I receive an error from the Mendix-built EmailTemplate module, which I believe is caused by an Eclipse bug. I’d like to be able to “Deploy for Eclipse” using a different Java version. Is this possible? Edit: I’m using Modeler version 7.23.7 and Eclipse version 4.15.
asked
1 answers
2

Just make sure the java version in eclipse is equal to the one in studio pro.

This can be changed under the preferences menu in Studio Pro I believe

answered