Cannot start in production or acceptance mode with security disabled

3
Hello, I have a project which I try to start as a service using Mendix Service Console. When starting the service I get the message "Unable to start the server. Reason: Cannot start in production or acceptance mode with security disabled. Any idea what I am missing. By the way: this is another application than the one I mention in another forum question.
asked
4 answers
5

In the project explorer: Project, Security and select production and check security .

answered
2

Hi Edward,

You should set your security level to production and completely configure the security before you put your project into a production environment. You have to configure adminitrator access, anonymous access, user roles and security for forms, microflows, entities and reports. The entity access per module only appear when the project security is set to production.

I would advise to set the security completely before you start with updating the production environment.

answered
2

You should never be able to run a project in acceptance or production with security disabled.

Note, however, that you're describing two different settings in the two projects you're running. In the one you (apparantly) have security completely disabled (this will trigger the exception you've mentioned)

In the other project you're describing the situation in which you have explicitly enabled security, but chosen to set "Check security" to "off".

The option to 'check security' only applies to what the modeler checks, not what happens at runtime.

answered
1

I have two projects. Project A is working fine, with security settings: Production + "Check security" = No.

Project B has exactly the same settings but gives this message. When I change Check Securiy to Yes it gives the same error.

answered