Testing a Mobile Native App

1
I have a problem testing a mobile native app using the “Make it Native” app on my mobile device. When I scan the QR-Code, it gives an error “unable to load script”. Is there a way I can use to solve this and be able to test my app?
asked
5 answers
0

Are you sure your mobile device is on the same network as your Mendix server?

The mobile devices need to be able to reach the ip address of the Mendix server.

 

I sometimes use my mobile device as hotspot for my laptop, which runs the server. That guarantees there are no firewall etc blocking communication.

answered
0

Both my mobile device and Mendix server are on the same network. 

answered
0

Hi Thulile, you can use React Native Debugger, take a look on this tutorial. https://aboutreact.com/react-native-debugger/

**Dont forget to change the port.

Make sure the port 8083 (default for native debug apps in Studio Pro) is also accessible externally in your computer and internet. Either port 8080 should be verified.

 

Regards
Diego Antonelli
Widgets Team – Mendix

answered
0

Hello Thulille,

 

This error occurs because of your desktops or laptops firewall. Not recommended but disable your all firewalls on your PC for a while and then try to relaunch Mendix Make it native app.  Hope fully it should connect now.

 

Ensure both your devices are connected to a common wifi network. Or simply connect your laptop with your same  mobile phones hotspot.

answered
0

The following steps worked for me to open my app within de the Mendix Native App and open my app in the browser when I fill in my IPv4 adres + :8080 (didn't have to disable my whole firewall):

First, the steps that Mendix recommends:
1. Be on the same network as your mobile device
2. On your computer with WiFi, set properties to "Private" instead of "Public"
3. In project settings under your 8080 server tick "open to other machines"

If it still doesn't work after this, which it was the case for me, you can try this:
1. To firewall & Network security
2. To advanced settings

3. Set OpenJDK Platform Binary to 'allow connection' and 'profile' = 'all':
Double click on the line -> check 'allow connection' -> go to tab 'advanced' and check all 3 profiles. See the photo below for an example of how the settings should look. (if needed, repeat this steps with the 'Mendix Native Mobile' line)
4. Check if it is working now. If not, you can still try the following steps.

5. Within the tab 'Rules for incoming connections' right click on the tab and then 'New rule'
6. Check the line type 'Port'
7. Choose TCP and fill in at 'specific local ports': 8080 (port 8083 may also be useful to allow, this uses Mendix in some cases)



8. Now it should work!

answered