mx8 modeler performance

4
Hi, After migrating from mx7 to mx 8 it feels/seems like the modeler is slower (and/or consumes more memory). Running it in a virtualbox has become a pain. Does anyone have any tips on how to make it run smother? Are there any settings that can be changed?   Kind regards Johan
asked
4 answers
3

I would try some of the following:

 

  • While it is not ideal, it may be worth not having too many project artefacts open  
  • Disabling Mendix Assist (Edit->Preferences->General->Mendix Assist->Enable Mendix Assist)
  • Playing around with the settings under Edit->Preferences->General->Error List->Auto check delay
  • Disabling some of the New Features under Edit->Preferences->New Features

 

Let us know how you get on.

Good luck!

answered
2

If the step Commit takes long, check in the project-directory if no unnecessary directories are being committed. Add them to the svn-ignore list.

answered
1

Increasing error check delay mitigated this issue for me.

answered
0

Even with the suggested settings I still have issues with performance in larger projects.

Is there more optimisation coming soon?

answered