Mendix Studio Pro 8.5 very slow

12
Hello guys Anyone else experiencing very slow performance on the Mendix Studio Pro 8.5 version? Saving takes about 4x longer, moving is very slow and mostly causes a programm crash, running the project takes longer… Pretty much everything just seems like its in slow-mo now.   Cheers Ron
asked
12 answers
7

We've been having this issue with 8.4.1 as well. Modeler performance seems to have worsened significantly

answered
5

Have to push this request up again. I experience the same issue in 8.5 as the other guys. Basically saving takes 5 to 10 seconds per changed element in the project explorer. Commiting takes very long, even shutting down the server takes almost 20 seconds now. Fingers crossed that this is going to be fixed with the next version already

answered
4

I started to work with the 8.5 on a new project. I noticed that as well. I hope Mendix solve it faster

answered
3

An update on this:

I worked around this issue on two sessions now, maybe one of you can try and verify as well:

  1. Run your slow project locally
  2. Open a second modeler and run any project – you will get the notification that the port is already in use
  3. stop your slow projects runtime
  4. stop your second modelers project runtime
  5. start your slow* project locally

 

Somehow that seems to work fine for me and I am interested in your attempts now

answered
3

Hey, Version Control team here!

Could you please elaborate on what do you mean by slow Commit performance? Which step do you mean?

We’ve seen some reports of “Refresh status information” step being slow, and we have dramatically improved the performance of this step in the upcoming Mendix Studio Pro 8.7.

answered
2

We also found this to be true, starting from 8.4.X.

Some of the slowness in functionality was caused by  “new features” that are not yet optimized. A great example is the autocomplete when searching, which takes up forever.

Go to “Edit → Preferences” and to the tab called “New Features”. Uncheck all the features you find and restart. This might speed up the modeller a little.

 

The slow compiling and running of the application will not be affected unfortunately.

answered
1

I am still experiencing this in modeler 8.6.1.

Everything i do in  studio pro gets some kind of delayed response. 

Saveing and running locally takes forever. 

I need to close and restart studio pro about 4 times during a workday to keep it workable. 

answered
1

I have the same issue on Mx8.6.4 which is supposed to be an LTS version. Mendix please take a look at this issue it is killing our team.

answered
0

Is there a better solution for this Modeler performance issues in Mendix 8.5 and 8.6?
The work around for the two sessions of the modeler only work for a short while for me.


 

answered
0

I am also using the Mendix Studio Pro 8.4.1 and it is very slow – Mendix should look into this – it is taking too much time to move objects, compile, commit, deploy !

answered
0

Maybe you should download mendix pro 8.11.0

answered
0

Any news on this? 8.6 is so slow.  Even getting after making and drinking a cup of coffee the modeller is not stopped.

answered