SSL error when loading app locally

0
Hello, I am followig the “Becoming a rapid developer” course on the Academy, and I am at the point where I should run the app locally to check it out, but I have an issue when I click the “View” button after having clicked the “Run locally” button. Chrome tries to load this URL: https://localhost:8080/index.html?profile=Responsive but it fails to load anything with this error: This site can’t provide a secure connectionlocalhost sent an invalid response. Try running Windows Network Diagnostics. ERR_SSL_PROTOCOL_ERROR   This is a screenshot of the error:   The same happens with IE or Firefox. I am running Mendix Studio Pro 8.4.1 Any suggestion on how I can fix this?   Thanks.
asked
2 answers
3

Hi Davide,

Can you try connecting to http://localhost:8080 instead of https://localhost:8080

 

Cheers,

Jeffrey

 

Edit1: Automatically reload for localhost can be changed:
Go to chrome://net-internals/#hsts. Enter localhost under Delete domain security policies and press the Delete button.

Now go to chrome://settings/clearBrowserData, tick the box Cached images and files and press click the button Clear data.

answered
1

I tried to, but Chrome automatically redirects to https.

But, if I open http://localhost:8080/ in an Incognito window, it actually works and loads my app.

So I assume this was just some Chrome quirk!

answered