Video Player Widget

1
Hi, I’m using the video player widget to display a mp4 file stored in my domain model in Studio Pro 8.4.1. I’m passing the string (for example): http://localhost:8080/file?fileID=30  to the widget. When I go to the page where the video is played I get the following: - the video failed to load :( - the video player is able to show the first image of the video but freezes immediately If I go to the widget and specify “Auto start” to “Yes” I get the following: - the video failed to load :( - but now the video plays well. only issue is I cannot pause or play the video. Any ideas on how to solve this? Many thanks
asked
2 answers
0

Hi Miguel,

I agree with the response from Mendix support. But this doesn’t answer your question. There could be a situation where  you only want to use one video for a small audience.

How to make this work in Mendix is as you described. Where it goes wrong (“the video failed to load :(“ message) is that you probably are retrieving the data through a data source Micro Flow. When you change this to context it will work.

answered
0

I got this reply from the Mendix support team:
 

The Video Player widget play videos from Youtube, Vimeo, Dailymotion and external Mp4 files, but not local files. Although in the limitations it states that files hosted in Mendix Server cannot be played in Safari browser, it is not recommend in general. Content distribution, especially video, is not scalable when going trough a Mendix application, as it can play for few users/videos but for something like 1000 videos/users, not.

I hope this clarifies your doubts.

Best regards,

Sergio Randazzo
Senior Technical Support Engineer

answered