Year Updates to 1900s When You Type Shorthand (i.e. 4/3/19) in DatePicker

1
Has anyone else had this issue? Changes to: when you tab out or hit enter.   Currently I’m in version: 8.2.2, but I did not notice until recently, so I’m unsure when this issue began. It was not an issue in 7, and I did not notice anything around this in the release notes for 8.3  
asked
3 answers
1

Indeed in Mx7 it works as it should. So my assumption is that this is a Mx8 bug. File a bug report.

Regards,

Ronald

 

answered
0

Hi Jordan,

  I have replicated this behavior and confirmed that indeed, numbers like 19 are auto-competed to 1919 when you tab out. Any 2-digit number in my browsers (edge, Firefox, and Chrome) auto-filled to 19XX. Three digit numbers filled to 0XXX. So, if you want to seize control of this, you are going to need to create a custom date format.

 When I create a custom date format (using the option in the Date Picker Widget from the radio button called ‘Date formar’) I could create a date format that is dd/MM/yy. When I do this, the browser is a little smarter. Any dates that end with 01-59 are auto-set to 20XX. Any year that is 60-99 is 19XX. I guess they figure that’s the best guess. 

 

 If you hate both of these, you could create an on-change widget.

answered
0

Yes, I am able to fix easily, however, the issue is that I don’t want to have to put custom date formats (and definitely not on change microflows) on every date in my entire system (there are quite a lot) if I can avoid it. It wasn’t an issue in 7, so I’m wondering what changed?

answered