Using password 1 for a user with administrator

3
Hi all, once again someone run into this super security feature. Accidentally an admin password is set to 1 and this is running on a cloud node. When (re)starting the application we get an error log and the application does not start. ERROR - Core: Using password '1' for a user with administrator user roles is not allowed. The following admin users have password 1 Now I’ve seen this issue once in a while in the forum and the usual solution is like: restore a backup with a not-so-stupid password. But what should I do if for some reason it is not possible or at least not so easy to do that? Isn’t there any other solution to get my application running again so I can then fix this issue from within the application? ** Addendum backup/modify/restore seems to be the only way to fix this currently (confirmed by Mendix Support)… 
asked
3 answers
6

In my opinion, this “feature” needs to be removed. Sure, it’s not a good idea to use “1” as password, but if your password policy allows it and it’s possible to change a password to “1” at runtime, the system should not block the startup. To me, this sounds like a platform bug.

answered
1

Why could you not create a backup of the current situation, run it local and change the password. Then make a backup again and upload it to the cloud?

Regards,

Ronald

 

answered
1

Turn-off the password policy,

deploy,

fix,

turn-on security policy,

deploy.

https://www.youtube.com/watch?v=wBoRkg5-Ieg

 

answered