Import Flat File

0
Hello everyone – I see various app store widgets for a flat file importer (my flat files are delimited by ^). However, those widgets are only available in an older version of Mendix. Since I’m on 8.1.0, is my best option to wait until Mendix or the widgets upgrade to that later version?
asked
9 answers
1

You can add the module you need (such as CSV) to a project in 7.23.X and then open that project in 8. It should convert it. That should see you through until the module you need is properly supported in 8.

answered
1

I have just updated the flat file importer module in the appstore, that allows for importing any delimited or fixed length file, to Mendix version 7.23.5.

Opening this version in Mendix 8 should work fine. I will add an update to Mendix 8 in the near future.

See: https://appstore.home.mendix.com/link/app/429/Erwin-'t-Hoen/Flat-&-delimited-file-import

answered
0

Hey Sue, 

I went through a series of Import conundrums myself and hence ask more out of curiosity than cause, have you tried using the excel importer? There also is a newer version of mendix itself (8.2). The excel importer works great on this :) let me know what you think!

Chai

answered
0

Thanks for that tip … I had seen Excel importers as well but held off because that would involve a step outside of Mendix to format the file as Excel … I’m surprised Mendix doesn’t offer this functionality out of the box

answered
0

Thanks – any advice/best practices if the file I need to import ISN’T on the cloud but rather on premise? Can I still use this tool and just manually drag-and-drop the file into it? I’ve imported the module into my project but am not seeing a way for a drag-and-drop … Is there another option for this?

answered
0

Thanks – any advice/best practices if the file I need to import ISN’T on the cloud but rather on premise? Can I still use this tool and just manually drag-and-drop the file into it? I’ve imported the module into my project but am not seeing a way for a drag-and-drop … Is there another option for this?

answered
0

I’ve clicked on “Internal Queue” checkbox to browse to a file and load it to see if that way would work on premise as it will be how I’m using in the cloud. I get this error:

The XML could not be parsed. Content is not allowed in prolog.
 at FlatFileInterface.ImportInterfaceDefinition_Step2 (Import with mapping : 'Import from XML')

 

Any ideas?

answered
0

Could this be causing some of the error: a column in the raw flat file may SOMETIMES be empty, and if it is, there is nothing populated in the file, e.g., if the file is delimited by ^, and a column is empty, then the file will show as ^^ (two delimiters in a row). Could that be the issue?

answered
0

Thanks for the clarification –added to queue and imported; error saying # columns doesn’t match import definition. I’m guessing it is because some columns null (and other times it may not be null, so unfortunately I cannot tell the import definition to skip those columns). How can I get around this?

answered