Creating pluggable widget throws an error

16
I tried creating a pluggable widget on Mendix 8 BETA 3 and used the Build Pluggable Widgets tutorial. When trying to test the widget i receive the following error:  React-Hot-Loader: misconfiguration detected, using production version in non-production environment. React-Hot-Loader: Hot Module Replacement is not enabled. The widget is not rendering. If tried reloading the library, or changing project settings, but it didn't work. Does anyone know what i’m doing wrong here?
asked
3 answers
2

Hi Henk, thanks for the question. We were investigating this in the past days, we found a solution and it will be released soon. We are just trying to fix the hot-reload (refresh) of the page before release.

You can track the progress here https://github.com/mendix/pluggable-widgets-tools

answered
0

Hi Henk, we released Widget Generator 0.1.6 that solves this problem with Hot Reload. For more information you can take a look on our Github repo → https://github.com/mendix/pluggable-widgets-generator

answered
-5

10 upvotes in 1 hour….. yeahright.

 

answered