Image uploader browser button is not working.

1
Hi everyone ! I’m having issues with an image uploader to upload a picture as a proof for an expense account. The browser button seems locked, and I’m unable to upload an image from the Responsive Browser. However, It works when I test the app on my phone. I also use Mendix Studio Pro 8.0.0 (BETA 2). The point of the app is to create expense account. The user can take picture as proof for their submitted charges, and then, a manager can accept the expense account or not.  Here is my Domain Model (sorry it’s in french, “justificatif” means “proof” , and “Frais” means “charge/fee”) :  Here is the screenshot of the Browser button that is not working :    Here is the page when you add the informations for the charge, and when you click on the “Action” button (it calls a microflow that you can see after), you can then add a proof picture :    Then, you go on this page, to upload your proof picture :    And here is the Microflow that you call when you click on the “Action” button earlier :    I can’t seem to figure this out, do you have any suggestions please ?    Thank you so much for the help !
asked
6 answers
2

The issue is a bug in Beta 2 atlas styling, This will be fixed in the next release.

To confirm that please  inspect the with browser dev tools and remove the classes form the upload button.

 

Cheers, Andries 

answered
2

 

It's now working fine by me in Mendix Studio Pro 8 beta 2. First i forgot to create an action button on the overview page to call a microflow. In your microflow you have to add a create object "Fraise" with output "NewFraise" then a create object "Justificatif" with output "NewJustificatif". After that add a change object with input variable "NewFraise" and add a new member of Justificatif with value $NewJustificatif. Add a show page for the Fraise object. (See example) Hope this will work.

answered
0

Are you logging in with the same user on your phone and on your desktop? Are you accessing different pages on mobile and desktop? If not, have you compared them? Have you checked all the editability settings of your data views?

I’m not sure exactly where your issue lies, but these are just some troubleshooting steps that came to mind.

answered
0

I’ve seen an issue where you can’t upload a file if you don’t have the object created already.

It does look like you are creating the object in the microflow. Have you confirmed the $NewJustificatif is what you are passing to the Show Page action?

Also I don’t think you need to pass this to the End Event, I’d try setting that to Nothing to see if it has any impact.

answered
0

Hi ! Thank you for your answer.

The $NewJustificatif was already passed to the Show Page action, as you can see below. 

I tried, as you said, to set the End Event to Nothing, but it doesn’t change anything concerning the browse action.

answered
0

Probably a bug, i encounter the same problem, security and inherited access rules are set accordingly.

A workaround for a small file(s):

1) decode your file to base64

2) Create a variable with that decoded base64 (hardcoded, watch out for a Out of Memory error )

3) generate a file by using base64tofile (communitycommons java action)

 

answered