Increasing session timeout

4
I’m trying to download an especially large file using a custom java RequestHandler, but since the process of downloading the file takes several minutes, I get the following error:   10:13:43 AM APP ERROR Connector: com.mendix.systemwideinterfaces.MendixRuntimeException: java.io.IOException: java.util.concurrent.TimeoutException: Idle timeout expired: 30000/30000 ms 10:13:43 AM APP INFO at com.mendix.util.classloading.Runner.doRunUsingClassLoaderOf(Runner.java:36) 10:13:43 AM APP INFO Caused by: java.io.IOException: java.util.concurrent.TimeoutException: Idle timeout expired: 30000/30000 ms 10:13:43 AM APP INFO at org.eclipse.jetty.util.SharedBlockingCallback$Blocker.block(SharedBlockingCallback.java:235) 10:13:43 AM APP INFO at org.eclipse.jetty.server.HttpOutput.write(HttpOutput.java:217) 10:13:43 AM APP INFO at org.eclipse.jetty.server.HttpOutput.write(HttpOutput.java:515) 10:13:43 AM APP INFO at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:2315) 10:13:43 AM APP INFO at org.apache.commons.io.IOUtils.copy(IOUtils.java:2270) 10:13:43 AM APP INFO at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:2291)   I have tried to adjust the SessionTimeout and EnableKeepAlive custom configurations in my Mendix Settings, but doing so seems to have no effect whatsoever on the above error. Furthermore, using  response.getHttpServletResponse().setHeader("Connection", "Keep-Alive"); response.getHttpServletResponse().setHeader("Keep-Alive", "timeout=1200, max=500"); request.getHttpServletRequest().getSession().setMaxInactiveInterval(1200); does not seem to have an effect either.   How can I increase the timeout duration to avoid the above error?
asked
1 answers
0

This page mentions that if you set the amount higher then a certain value it might be ignored, could it be that you set the value to high?

https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Keep-Alive

answered