Spiderchart with static scale

0
I am trying to configure a scatterpolar chart widget to use a static yScale. The scale is now adapting to the minimum and maximum value of the data. But I would like to use a static scale from 0 to 5. What am I doing wrong? The widget is not listening to the yScale keyword. [   {     "type": "scatterpolar",     "r": [       1,       4,       3,       2,       3,       2     ],     "theta": [       "A",       "B",       "C",       "D",       "E",       "F"     ],     "fill": "toself",     "fillcolor": "#709BFF",     "line": {       "color": "black"     },     "yScale": {       "minimum": 0,       "maximum": 5     }   } ]  
asked
2 answers
0

The JSON is configured ok, no problem there.

What chart-widget are you using?  And is it case-sensitive? Does it accept yscale? Does it yscale as a configuration setting at all?

If it is plotly.js, that one does not seem to have yscale as setting: https://docs.mendix.com/refguide/charts-any-cheat-sheet

Maybe your scatterdiagram listens to this setting:

  yaxis: {
    range: [0, 5]
  }

 

answered
0

Solved it. In Static Layout:

{
  "polar": {
    "radialaxis": {
      "visible": true,
      "range": [
        0,
        6
      ],
      "autorange": false
    }
  }
}

 

answered