Setting Up new Mendix DB on Microsoft SQL Server 2017

0
I’m attempting to setup a database on Microsoft SQL Server (Developer) and am following the instructions found on the Mendix site:  https://docs.mendix.com/developerportal/deploy/setting-up-a-new-sql-server-database.    When I execute:  CREATE ASSEMBLY [Mendix.SqlServerExtensions] FROM "C:\Program Files\Mendix\7.23.1.46759\runtime\lib\Mendix.SqlServerExtensions.dll" WITH PERMISSION_SET = SAFE;   I’m getting the following error from SQL Server:   Msg 128, Level 15, State 1, Line 1 The name "C:\Program Files\Mendix\7.23.1.46759\runtime\lib\Mendix.SqlServerExtensions.dll" is not permitted in this context. Valid expressions are constants, constant expressions, and (in some contexts) variables. Column names are not permitted. Msg 319, Level 15, State 1, Line 1 Incorrect syntax near the keyword 'with'. If this statement is a common table expression, an xmlnamespaces clause or a change tracking context clause, the previous statement must be terminated with a semicolon.   I believe this is the reason I’m not able to connect the modeler to the local SQL Server. Is there another way of installing the Mendix SQL Server Extensions?   This is also preventing me from completing step 4.1.    When I attempt to connect from the Mendix Modeler 7.22.1.     I get the following connection error:   Opening JDBC connection to Some(localhost) failed with SQLState: 08S01 Error code: 0 Message: The TCP/IP connection to the host localhost, port 1433 has failed. Error: "Connection refused: connect. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall.". Retrying...(1/4)     Any help in resolving this would be greatly appreciated. A pity this isn’t as simple as using PostgreSQL. 
asked
1 answers
1

It sounds like the network configuration for your instance of SQL Server may not be configured correctly.  Run the SQL Server Configuration Manager utility (it should be listed in your installed programs) and go to the Network and Client protocols, and make sure that TCP/IP is enabled.  I’m not sure which one is causing your issue, so check both versions of the SQL Native Client and the Server Network Configuration

answered