Application node does not start after clear environment

1
In an existing Mendix cloud node I want to temporarily use the acceptance environment to give a Demo for another Mendix project. In order to do this, I have created an MDA from the modeler and uploaded this. Then I stop the Node with the application from an older project and select the clear environment button. When I the deploy my Demo MDA and press start, the application does not start. I recieve a pop-up "Starting application failed" with a link to view the log. In the application log all I see is: Jan 4 13:10:18.045 127.0.0.1 tr10000: INFO - Core: Mendix Runtime 6.0.1 (build 6707). Copyright © 2003-2015 Mendix bv. All rights reserved. Jan 4 13:10:18.722 127.0.0.1 tr10000: INFO - XMPPConnector: appnode-salmon-tr10000@beta.mendixcloud.net connected. Jan 4 13:10:18.727 127.0.0.1 tr10000: INFO - XMPPConnector: Registered 'cp@beta.mendixcloud.net/Smack' as cloud portal contact Jan 4 13:10:18.984 127.0.0.1 tr10000: INFO - Logging: Logging to file: /srv/cloud/slots/tr10000/deploy/data/log/m2ee.log, max size: 2048KiB, max rotation: 10 Jan 4 13:10:21.709 127.0.0.1 tr10000: INFO - Core: Mendix Runtime is now shut down. Does anyone have any suggestions why the application cannot be run?
asked
2 answers
0

Ralph,

I am not entirely sure, but it seems to me that a licensed App is tied to a particular cloud node (or set of cloud nodes, like Acceptance/Production, etc.). So trying to run an App that is not tied to that cloud node within the node will not work. Maybe Mendix could chime in here and confirm if this is the case.

On a separate note, is there any reason you can't do your demo using a Sandbox deployment?

Mike

answered
0

Hello Ralph, Please make sure that the node you are deploying is a licensed node and that you have the correct node security setting permissions. Also an attempt to deploy to another node could rule this and other troubleshooting thoughts out of the question. Please try this as well. If you have not done so already please submit a support ticket and we will look at the runtime connections, the specific cloud node connection, appnode-salmon-tr10000, etc., Keep note there is a similar ticket, so other developers may have experienced the same XMPP connection issue. http://mxforum.mendix.com/questions/6550/something-went-wrong-while-deploying-your-app-to-the-sandbox Thanks, Michael Schlosser

answered