Error connecting debugger to server

0
I have been successfully connected the debugger to the server. Suddenly when I try I get the message below. This is happening on multiple projects, including ones I had successfully connected to before. I have tried restarting the modeler, the app and rebooting Windows. Mendix.Modeler.Microflows.Debugger.DebuggerException: Failed to parse response text for startsession request. Response text: <html> <head> <meta charset="utf-8"> <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> <title>Mendix 5</title> <meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1, maximum-scale=1"> <meta name="apple-mobile-web-app-capable" content="yes"> <link rel="stylesheet" href="lib/bootstrap/css/bootstrap.min.css"> <link rel="stylesheet" href="mxclientsystem/mxui/ui/mxui.css"> <link rel="stylesheet" href="css/theme.css"> </head> <body dir="ltr"> <script> dojoConfig = { rtlRedirect: "index-rtl.html", baseUrl: "mxclientsystem/dojo/" }; </script> <script src="mxclientsystem/mxui/mxui.js"></script> </body> </html> ---> Newtonsoft.Json.JsonReaderException: Unexpected character encountered while parsing value: <. Path '', line 0, position 0. at Newtonsoft.Json.JsonTextReader.ParseValue() at Newtonsoft.Json.JsonTextReader.ReadInternal() at Newtonsoft.Json.JsonTextReader.Read() at Newtonsoft.Json.Linq.JObject.Load(JsonReader reader) at Newtonsoft.Json.Linq.JObject.Parse(String json) at Mendix.Modeler.Microflows.Debugger.DebuggerResponse..ctor(String requestActionName, String responseText) in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.Core\Microflows\Debugger\DebuggerResponse.cs:line 12 --- End of inner exception stack trace --- at Mendix.Modeler.Microflows.Debugger.DebuggerResponse..ctor(String requestActionName, String responseText) in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.Core\Microflows\Debugger\DebuggerResponse.cs:line 23 at Mendix.Modeler.Microflows.Debugger.DebuggerClient.PerformRequest(DebuggerRequest request, Int32 timeout) in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.Core\Microflows\Debugger\DebuggerClient.cs:line 166 at Mendix.Modeler.Microflows.Debugger.DebuggerClient.StartSession(IEnumerable1 breakpoints) in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.Core\Microflows\Debugger\DebuggerClient.cs:line 64 at Mendix.Modeler.Microflows.Debugger.DebuggerController.StartDebugging(String url, String password, ConnectionMode mode) in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.Core\Microflows\Debugger\DebuggerController.cs:line 95 at Mendix.Modeler.Microflows.Debugger.DebuggerControl.<>c__DisplayClass2b.<StartDebugging>b__27() in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.Core\Microflows\Debugger\DebuggerControl.cs:line 304 at Mendix.Modeler.Utility.BackgroundUtil.<>c__DisplayClass61.<do>b_4(Object s, DoWorkEventArgs e) in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.Utility\BackgroundUtil.cs:line 28 at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e) at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
asked
2 answers
1

Are you sure you're pointing the modeler to the correct debugger link? It's usually your app address and then /debugger/.

The reason I ask is that the error you posted includes the contents of the regular index.html page.

answered
0

When attempting to run locally I get this: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made

However I realize yes my app is in the Sandbox. I use the correct URL and password provided in the deployment activity within the project, but maybe my app- because it is not a node -will not connect to that specified location... it is time to get a license!

answered