How can attributes from a different entity be shown in a list view (Rapid Developer course)?

0
Hi, in the Rapid Developer course I'm having trouble with the Training Event Overview page in Module 4.7.2. As soon as I replace the Caption of the text from e.g. Title to {1}, after adding the attribute  MyFirstModule.TrainingEvent_Course/MyFirstModule.Course/MyFirstModule.Course.Title the page TrainingEvent_Overview will not show anymore (Run locally - View > Responsive Browser); the app hangs. When I change it back to a fixed text, the page shows again. I don't know how else to refer to an attribute from a different entity? Attributes Start Date and End Date do show properly. Also, the detail page TrainingEvent_NewEdit (with the references) works fine. In the Modeler I see the following error: Kan de eigenschap status van een niet-gedefinieerde verwijzing of een verwijzing naar een lege waarde niet ophalen TypeError: Kan de eigenschap status van een niet-gedefinieerde verwijzing of een verwijzing naar een lege waarde niet ophalen    at g (http://localhost:8080/mxclientsystem/mxui/mxui.js?636862600388648002:20:3019)    at s (http://localhost:8080/mxclientsystem/mxui/mxui.js?636862600388648002:46:255509)    at e.prototype.getByPath (http://localhost:8080/mxclientsystem/mxui/mxui.js?636862600388648002:46:215861)    at Anonymous function (http://localhost:8080/mxclientsystem/mxui/mxui.js?636862600388648002:46:179045)    at Anonymous function (http://localhost:8080/mxclientsystem/mxui/mxui.js?636862600388648002:46:178939)    at p (http://localhost:8080/mxclientsystem/mxui/mxui.js?636862600388648002:46:178910)    at Anonymous function (http://localhost:8080/mxclientsystem/mxui/mxui.js?636862600388648002:87:160388)    at Anonymous function (http://localhost:8080/mxclientsystem/mxui/mxui.js?636862600388648002:87:156388)    at Anonymous function (http://localhost:8080/mxclientsystem/mxui/mxui.js?636862600388648002:87:156360)    at Anonymous function (http://localhost:8080/mxclientsystem/mxui/mxui.js?636862600388648002:87:156527) Since I'm a newbee here, I could use some adviceā€¦ Thanks!
asked
2 answers
1

My guess is that the object isn’t committed and the label is trying to retrieve from the db, hence hitting a null exception.

I suggest using a data view for the related course entity, which you populate via association. Then in that view you can place the label that references the title attribute.

Hope this helps

answered
0

Uh-oh, the same error occurs on the TrainingEvent_Overview to Registrations button. I didn't manage to fix that one, where the Title should contain a Name from Course and a Date from TrainingEvent_Registration - I cannot pick the correct entity in the Connect-tab. So I imported the file from the Resources tab in Module 6, but this source gives the same error! Support says there's no bug in the source, so now I'm lost again…

Anyone else have this problem? Or is it best to create a new Question for this?

answered