Disable multiple clicks on a button

0
Hi All,  I am working on Mendix 7.15.1, I have a button that calls a microflow and the disabled during action property is set to true,  and execution microflow settings are blocking, synchronous and there is an ask confirmation. however when the button is clicked twice the confirmation popup is showed twice! and on every 'Yes' the microflow is executed! I want to disable multiple clicks on the button!  anyone have an idea?  
asked
3 answers
2

yes there was a bug with disable during action indeed, it was fixed in 7.17

 

https://docs.mendix.com/releasenotes/desktop-modeler/7.17

 

answered
0

Sounds like a bug, I suggest checking the patch notes, and see if this is fixed in one of the following versions. 

As a workaround you could place an intermediary pop-up page with your confirmation, and then add your microflow on the "Yes" button without the confirmation (I think this should work as expected).

Hope this helps

answered
0

you could have 2 buttons that are styled the same.
have them in conditional visability, and in the micro flow switch the 2 out.
This is a pretty dirty way to fix it, and like Dragos said, its probably a bug. but it might solve the issue if you need a quick and dirty fix

answered