RUN LOCALLY ERROR

1
I tried running my app as local server but I got the following error **No permission to open socket or another server is already running on localhost:8080: Address already in use: JVM_Bind Mendix.Modeler.M2EEConnector.M2EEException: The server encountered an error. at Mendix.Modeler.M2EEConnector.M2EEResponse.CheckSuccess() in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.M2EEConnector\M2EEResponse.cs:line 57 at Mendix.Modeler.M2EEConnector.M2EEClient.UpdateAppContainerConfiguration(Int32 port, String listenAddresses) in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.M2EEConnector\M2EEClient.cs:line 131 at Mendix.Modeler.M2EEConnector.StartupManager.PerformStartup(StartupInfo info, IM2EEClient client) in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.M2EEConnector\StartupManager.cs:line 23 at Mendix.Modeler.M2EEConnector.RuntimeController.Start(StartupInfo info, LogLevel autoSubscribeLogLevel) in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.M2EEConnector\RuntimeController.cs:line 132 at Mendix.Modeler.Deployment.Local.LocalRunner.<runtimelaunched>b9() in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.Deployment\Local\LocalRunner.cs:line 246 at Mendix.Modeler.Utility.BackgroundUtil.<>cDisplayClass6`1.<do>b__4(Object s, DoWorkEventArgs e) in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.Utility\BackgroundUtil.cs:line 28 at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e) at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)**
asked
5 answers
6

This means that the port is already in use by something else (or another instance of Mendix). Goto Project / Setting and edit your active setting to localhost:8000 for instance. If you use postgres use the portnumber of your postgres settings (most of the time 5432).

Regards,

Ronald

answered
4

In mendix modeller - >

Go to project settings -> Configurations tab -> Edit (configuration name) -> Go to server tab -> Change Runtime port from 8080 to 8888 -> Click on OK 
Try running locally. 
This worked for me.

answered
2

Hi guys, I'm having a similar issue as above and I have changed the localhost port several times but that doesn't seem to help at all. Any ideas what I should be looking at next?

Exact error message is... Mendix.Modeler.M2EEConnector.M2EEException: The server encountered an error. at Mendix.Modeler.M2EEConnector.M2EEResponse.CheckSuccess() in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.M2EEConnector\M2EEResponse.cs:line 57 at Mendix.Modeler.M2EEConnector.M2EEClient.ExecuteDdlCommands(DdlCommands ddlCommands, String ddlCommandsLogDir) in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.M2EEConnector\M2EEClient.cs:line 247 at Mendix.Modeler.M2EEConnector.StartupManager.StartRuntime(IM2EEClient client, StartupInfo info) in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.M2EEConnector\StartupManager.cs:line 104 at Mendix.Modeler.M2EEConnector.StartupManager.PerformStartup(StartupInfo info, IM2EEClient client) in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.M2EEConnector\StartupManager.cs:line 47 at Mendix.Modeler.M2EEConnector.RuntimeController.Start(StartupInfo info, LogLevel autoSubscribeLogLevel) in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.M2EEConnector\RuntimeController.cs:line 139 at Mendix.Modeler.Utility.BackgroundUtil.<>cDisplayClass6`1.<do>b4(Object s, DoWorkEventArgs e) in c:\jenkins\workspace\AppStudio-Modeler\src\Mendix.Modeler.Utility\BackgroundUtil.cs:line 28 at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

answered
1

In mendix studio pro 8.18.1  go to Language>Language settings>> Configurations tab  and 

Go to  Language-->Language settings--> Configurations tab --> Edit (configuration name) -> Go to server tab -> Change Runtime port from 8080 to 8888 -> Click on OK 
Try running locally. 
This worked for me.

answered
0

Hi guys,

I'm facing a similar issue as above where I using postgresql and I have changed the localhost port several times but that doesn't seem to help at all. Can you help me out with this issue?

Mendix.Modeler.M2EEConnector.M2EEException: The server encountered an error.
   at Mendix.Modeler.M2EEConnector.M2EEResponse.CheckSuccess() in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.M2EEConnector\M2EEResponse.cs:line 57
   at Mendix.Modeler.M2EEConnector.StartupManager.PerformStartup(StartupInfo info, IM2EEClient client) in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.M2EEConnector\StartupManager.cs:line 27
   at Mendix.Modeler.M2EEConnector.RuntimeController.Start(StartupInfo info, LogLevel autoSubscribeLogLevel) in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.M2EEConnector\RuntimeController.cs:line 133
   at Mendix.Modeler.Utility.BackgroundUtil.<>c__DisplayClass1_0`1.<Do>b__0(Object s, DoWorkEventArgs e) in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.Utility\BackgroundUtil.cs:line 28
   at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

answered