Api level requirements for Android 8.0

1
Hi all, It is now required to use target API level 26 for Android 8.0. I simply changed <preference name="android-targetSdkVersion" value="23" /> to value 26 in my cordova package and i thought i would be done. However the app doesnt start anymore if I do that.  I'm quite new to cordova, does anybody know how to fix this problem?
asked
1 answers
2

Hi Hunter, the API level 26 is not a requirement due late 2018, see https://android-developers.googleblog.com/2017/12/improving-app-security-and-performance.html

When reverting back to API level 23, you will find that Play will just give you a warning. 

Edit:

For what I remember (not confirmed) you need to remove the crosswalk webview plugin in order to make it work for  API level 26. To disable crosswalk you need to comment out the cordova-plugin-crosswalk-webview and com.crosswalk.cookies plugins

Can you disable the crosswalk plugin and tell us the results?

answered