(possible) Timeout on microflows in Mendix 7

0
Hi all, We did an upgrade from Mendix 6.10 to 7.13.1. When we debug our application we get an connection error, after about 5 seconds. This systemtext is saved under the 'Mobile common - connection error' . This is not a real problem, however when we have microflows that take a long time to load due to REST services we get the error as well. Is it possible to change this timeout? Because our REST service works (but is slow) and the screens after the microflow do as well. Greetings, Niels de Haas
asked
2 answers
1

Hi Dennis,

We actually fixed this problem. First I would like to say that you can run microflows asynchronously, as described in this blogpost:
https://www.mendix.com/blog/take-a-time-out-to-learn-about-asynchronous-calling/

However this does not always suffice, for instance calling a microflow from a navigation list does not seem to have an option to call it asynchronously. That's why we decided to increase the timeout value. You can do this by changing the DojoConfig.server.timout field in the index.html of your application, like so:

            dojoConfig = {
                baseUrl: "mxclientsystem/dojo/",
                cacheBust: "{{cachebust}}",
                rtlRedirect: "index-rtl.html",
                server: {
	                timeout: 5000
	            }
            }


For more info see:
https://dojotoolkit.org/documentation/tutorials/1.10/dojo_config/


Our situation was a bit different so please let me know if this worked in your app! :)

Greetings,
Niels de Haas

 

answered
0

Hi Niels,

we experience the same issue on a tablet. Did you get a solution for the problem stated?

Regards Dennis

answered