Page URL redirects to login page when using an id (/pagename/{id})

0
If I try to open a URL for a page with a parameter that a user has access to, I am asked to log in. If I open a URL for a page that does not require a parameter the page opens correctly. I am testing as follows: Log in Navigate to the page that requires a parameter Copy the URL (http://localhost:8080/p/Answer/16325548649220205) Navigate to another page Paste the URL (http://localhost:8080/p/Answer/16325548649220205) and hit enter. I am taken to the log in screen. If I log in, I remain on the login screen. What could I be doing wrong?  Thanks, EDIT: I simplified testing. Navigate to a page using the user interface so I can see the URL (http://localhost:8080/p/AnswerQuestions/16607023625930205?profile=Responsive). Either click the browser's refresh button OR Click on the address bar and hit Enter I'm taken back to the Login screen and if I sign in I'm taken to the login screen again. If I hit the View button on the Modeler, the app runs in a new tab and I'm already logged in. Same behavior in Chrome, Edge, and Firefox. Also tried using different pages in my app and get the same result.  
asked
2 answers
3

Hi Marcos,

What I suspect you are running into is a security isssue. The [id] you are referring to, in this case, for the answer object, is the record associated to the data view object that is required on that particular page to make it populate. That record requires that the user in your app model has security access to view it, and that is why you are being prompted to login when trying to navigate directly to the URL. Take a look through section 4.3 on the URL here and see if this doesn't help you troubleshoot it: https://docs.mendix.com/refguide/page

answered
0

Hi Marcos,

Are you using the deeplink module to do this? If so, can you post your deeplink configuration?

answered