mendix error the latest revision was committed with version (unknown)…

0
I am getting the following error message when I go to update a branch I have downloaded from the Team Server:   The latest revision was committed with a version (unknown) of the modeler. Please install that version first.   On the Team Server, I see that the branch was also created with version "Mendix (unknown)". I wonder what happened to cause this error when we created the branch
asked
2 answers
3

I'm just going to post an answer to this pretty old question as I've just run into this myself and had to contact Mendix support to solve it. 
This happens when creating a branchline from a tagged version. However, you will not get a warning or error, that will happen once you're trying to merge your (hours worth of) changes.

I've created a ticket for this, as this still happens in 7.13.1

There is a workaround for merging you changes however. You will have to do this outside of the modeler with TortoiseSVN 1.7.15 and you'll be doing this at your own risk.
1. Close your Mendix project.
2. Right click the project folder and choose "Merge" from the TortoiseSVN menu
3. Choose 'Merge a range of revisions'
4. Browse the repository and select the folder that corresponds with the branch you want to merge (into the line you selected in part 2)
5. Select the revisions you want to merge
6. You will have to option to 'Test merge'. Try it and if you get a conflicted .mpr file, that is OK and is supposed to happen.
7. Merge for real now
8. Open your project and it will prompt a saying there's been a merge outside the modeler. Let the modeler take it from there.
 

answered
0

I would expect this to happen when the branch was not created form within the modeller, but within some other SVN client (Tortoise for example).

Mendix relies on commit metadata to determine the model version number, which is obviously failing here. You could manually do a new commit on this branch with an svn client and set the correct metadata with that commit, which should fix this.

answered