How to check the current version of a widget used in the project?

0
I ran into an issue while using a widget. I searched the forum and found a thread about the same issue, and the issue should be resolved in the latest version of the widget. So far so good, but I was doubting whether or not I already used this version. How can I check what the version of a widget in my project is?
asked
2 answers
3

Hi Stefan,

 

The widgets for your project are located in a folder called "widgets". They have the  .mpk extension but they are in fact just zip files so you can extract them using any compression software. Afterwards you can check the package.xml file to see the version 

//package.xml

<clientModule name="MyCustomWidget" version="1.0" xmlns="http://www.mendix.com/clientModule/1.0/">

I hope this helps,

answered
4

I created a tool that makes it able to search for deprecations in widgets: https://github.com/mendix/mx-check-deprecations

Using this tool, you can run it with --verbose

This will tell you which XML version number every widget has. I run this in a project and get an output like this:

 StyleSheetSwap/widget/StyleSheetSwap.js has no results
 ==========================================================================
 File:                TooltipLink.mpk
 Widgets:
                      TooltipLink.widget.TooltipLink : TooltipLink
 Package.xml version: 1.3
 ==========================================================================

 TooltipLink/widget/FormTooltip.js has no results
 TooltipLink/widget/MasterTooltip.js has no results
 TooltipLink/widget/Templated.js has no results
 TooltipLink/widget/TooltipLink.js has no results
 ==========================================================================
 File:                URLRedirector.mpk
 Widgets:
                      URLRedirector.widget.URLRedirector : URLRedirector
 Package.xml version: 1.1
 ==========================================================================

 URLRedirector/widget/URLRedirector.js has no results
 ==========================================================================
 File:                VectorGauge.mpk
 Widgets:
                      VectorGauge.widget.VectorGauge : VectorGauge
 Package.xml version: 1.0.0
 ==========================================================================

 VectorGauge/widget/VectorGauge.js has no results
 ==========================================================================
 File:                youtube.mpk
 Widgets:
                      youtube.widget.youtube : youtube
 Package.xml version: v2.0
 ==========================================================================

 youtube/widget/youtube.js has no results

 

answered