Large datasize / change com.mendix.webui.StateSizeWarningThreshold

0
How can I change the com.mendix.webui.StateSizeWarningThreshold  as is suggested in https://docs.mendix.com/refguide7/transient-objects-garbage-collecting ? We have a large dataset (approximatly 10.000 samples) which is requisted by a rest service and thereafter processed and displayed. The data is retrieved in a non-persistent entry. This worked fine in Mendix 6 (processing in 3 a 4 seconds). When changed to Mendix 7 a user error pops up every time the microflow is called and log shows: "Feedback size of 8044 exceeds threshold of 5000 items which can result in severe performance problems.". However, processing is still done correct and processing time is still aceptable. So we are faced with an "incorrect error message" displayed to user while the correct results are obtained.  According to the above refquide this behaviour now occurs in Mendix 7 as garbage collection is done at client side and limit for non persistent entires is set to 5000 items. The issue can be prevented by increasing StateSizeWarningThreshold. So we now want to increase this parameters to 10.000.  Any examples on how to change this Threshold ? (were to find it ?) 
asked
4 answers
3

If I'm correct you can change these settings in Sprintr/ the Mendix platform.

In order to do this you'll need to go the environments, select the environment and go to the runtime tab. Here you can add Custom Runtime Settings.

answered
0

Anyone can able to answer this please. I try to configure under mxruntime on m2ee.yaml but it does not work, still have an error message limit at 5000 records

answered
0

I would try it in custom settings

answered
0

Project > Setting > Select Configuration > Custom Tab > Add New Custom setting

com.mendix.webui.StateSizeWarningThreshold = 100000

Run locally and got en warning on modeler console logs

message error: Feedback size of 5749 exceeds threshold of 5000 items which can result in severe performance problems.

answered