Grow automatically : NO --> not working

0
Hi Team,   I am using mendix 6.7.1 and found that grow automatically No is not working if I change editable to Never. Expected scroll bar appended to text area if number of lines mentioned in property settings exceeds.
asked
4 answers
2

So the bad news is that this is the result of the fact that any default widget (text input, text area, boolean, etc.) in Mendix versions prior to 6.9.0 will always print your content as label, reducing your control over how it's displayed. Labels simply show all contents as "text".

The good news is that version 6.9.0 introduced a Read-only style, where you can choose between Text or Control. The latter option results in your textarea showing up as textarea in read only mode. In a test project I created in 6.9.1, setting this option to Control resulted in the behaviour you're looking for as can be seen below:

 

If at all possible, my advise would be to upgrade (also because I know this will be the answer from Mendix Support if you file a ticket).

answered
1

Swathi,

If you don't see a scrollbar in the case where the length of the text exceeds the number of lines, that does appear to be a bug.  I would suggest filing a ticket with Mendix.

Mike

answered
0

Hi Swathi,

I've done a quick test in 7.0.2 and I see the same issue there. So I agree with Mike and file a ticket with Mendix.

Screenshot:

answered
0

Seems to me this problem is still existing. Will it not be fixed? If a field is editable:never and grow automatically. We get no scrollbar and the size is fixed.

answered