Opening JDBC connection to Some(localhost) failed with SQLState

0
Hi, I have installed a Mendix upgrade (v6.8.1). when I try to run it locally I got below error: 'Opening JDBC connection to Some(localhost) failed with SQLState: 08001 Error code: 0 Message: Connection to localhost:5432 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections. ' While with my old version I didnt have any issue. I didnt change any DB config either. Can anyone help? Thanks! Chang
asked
3 answers
2

My colleque Dick found out that the DeepGuard functionality of F-Secure was causing the problem. This functionality puts PostgreSQL (postgres.exe) on the list of applications to check. Presumeable this check is to slow. There is no option to make an exception for excluding postgres.exe from this check. So DeepGuard needs to be shut down completely.

answered
0

I've got almost the same message: Opening JDBC connection to Some(localhost:5432) failed with SQLState: 08004 Error code: 0 Message: Connection rejected: could not fork new process for connection: No error. Retrying...(1/4)

This problem occurred after we migrated from Mendix 4 to Mendix 6. It has not to do with firewall settings because the issue occurs on the acceptance environment as well. The database is postgresql 9.4

answered
0

I'm having similar issues with Postgres the last two weeks now. No change in Postgres, with Mendix projects that worked flawless before.

I think it is some windows 10 issue. I have changed the Postgres service to auto start with delay, which seems to help.

I noticed that one of the postgres processes puts a really heavy load on the SSD for about a minute or so. It then complains in the log that the server was not stopped correctly. 

Maybe windows stops the processed too brutally or something changed in the way the OS signals that it is about to shut down, which postgres does not pick up correctly.

Seems a windows or postgres issue rather than a Mendix issue.

Edit: I no longer start the service manually using net start, it seems postgres does not shutdown properly when started this way. So no real solution yet.

answered