File manager upload widget does nothing when clicking Browse

1
Is there any reason why nothing happens when browse is clicked?
asked
7 answers
2

It could be empty or access security

Never set any access properties on System.FileDocument or System.Image (other than MxAdmin for security reasons) Always make generalization from Filedocument / Image and set your property.

I could also be styling. I have seen some strange things (see answer): https://forum.mendix.com/questions/6961/Is-there-a-problem-with-the-file-document-upload-on-IE8-and-IE9-

answered
0

check your access rules also and the security for documents/images

answered
0

I had the same issue, Browse button does nothing. I found the problem.

You need to create before hand your FileDocument object (generalization of System.FileDocument) through a micro flow and attach it to the current view object in page.

Hope this helps.

answered
0

A good workaround for now is to choose picture instead and give the picture the same dimensions as your thumbnail would have had

answered
0

Hi,

I'm encountering the same issue, I tried:

  • different browsers (Chrome, Firefox, Edge, with and without a pop-up blocker)
  • the style-fix (.btn { opacity = 1 !important; } )
  • the security rules are completely off (nor do I see security rules applied to System.Image)
  • the object inherits from System.Image, as suggested in the Mendix Documentation, which then is linked to an entity ("Product")
  • I get no errors, the application builds and runs locally and in the Mendix cloud
  • Edit: tried to add it in a separate page: no success either

Yet: the 'Browse'-button doesn't do anything once I click on it... Any other suggestions?

Thanks in advance.

Kind regards,

Leander

---

Edit2: solved! The "error" occured because I created an extra entity 'ProductImage' and this was apparantly too difficult to handle correctly. If I let the Product-entity inherit from System.Image, everything works as expected. My bad!

answered
0

I have the same issue and I can't seem to solve it. The problem is that any entity that inherits from System.FileDocument seems to not respond to "Browse". That means that i.e. i can't upload either new TableMappings from XML (since DatabaseReplication.XMLDocumentTM inherits from System.FileDocument) or any ExcelDocuments. I also have entities that inherit from from ExcelImporter.TemplateDocument (which I have customized a bit with some new parameters) and these are of course also totally broken.

I did do some changes in my Security Rules and know that those changes can trigger strange behaviour without any form of feedback, so I checked and double checked them and they should work, but no change.

Getting very frustrated...

Mendix: 7.20.0

answered
0

HI,

I tried  every knowledge in this page, but it doesn’t work.

Is there any idea to solve it?

answered