Excel Importer module: Document could not be imported, because: Error while processing the MetaInfoObjects

1
I am using the Excel Importer module and it works fine, unless I edit a template that has also reference to imported objects. In details: I had a template that was importing 2 columns, one was the attribute of an entity and the other was the attribute of the referenced entity (also used as a key). The import was working. Then, I wanted to import one more column for my entity (not the referenced one), so I tried to edit the template and add 1 more column as an attribute for my entity. When tried to import by using the updated template, I got an errror (An error has occured while handling your request), and the details can be seen below: "com.mendix.modules.microflowengine.MicroflowException: com.mendix.core.CoreRuntimeException: com.mendix.core.CoreException: com.mendix.core.CoreException: Document could not be imported, because: Error while processing the MetaInfoObjects: replication.ReplicationSettings$MendixReplicationRuntimeException: com.mendix.core.CoreRuntimeException: com.mendix.core.CoreRuntimeException: com.mendix.core.CoreRuntimeException: com.mendix.core.CoreRuntimeException: An error occurred while executing the action 'MyFirstModule.ACCheckDailyExpCleaning' | VERSION: Mx520140707 at ExcelImporter.IVK_ImportTemplateDocument (JavaAction : 'StartImportByTemplate')" The microflow mentioned is a microflow used to calculate another attribute of the entity I am importing and before editing the template, it was not causing any errors. Deleting and recreating the template was giving the same error as well, when trying to import the file using the template. At the end I had to delete all excel import module, re-import it and create all templates from scratch. Any idea on what causes this error and what other ways are to fix it (apart from re-creating the whole excel import module)?
asked
2 answers
3

Hi Maria, This issues has just been reported and fixed. We are currently still testing this change before it can be released to the appstore.

FYI, the reason for this is indeed the reference, if there is an empty cell you will get this error message. If all cells in that column have a value you won't get that error message.

answered
0

Is there any update regarding the bug fix for the excel import module?

answered