Excel import not working.

0
Dear reader, In a simple app I created one entity "Airports", with the columns Code and Name. I then added the modules MxModelReflection and ExcelImporter. When I try to import a simple Excelsheet (made with Excel 2013, but with the extension .xls) with the name of the two columns Code and Name on row 1 and the data from row 2, then the result is: Statistics - FINAL statistics, Objects of type 'MyImportExcel.Airports' Created: 0 Synchronized: 0 Not found: 0 Skipped: 0 The documentation says: "There are several lognodes available in the Excel importer and replication module. These nodes support several levels (info, debug, trace). When you want to find out where the problem is caused just change the loglevels to debug or trace. This way you will see all the actions the excelimporter does to the objects. The module uses the following lognodes: ExcelImporter, ValueParser, ReplicationMetaInfo, ReplicationMetaInfoAssociatedObjects and ReplicationMetaInfo_MainObject" My question is: how can I set these lognodes to TRACE? My real question is: Why is my excel-import not working?
asked
2 answers
1

When running the app from the modeler you can set the loglevels on the console tab in the modeler. Select the console tab, select the advanced dropdown and then set loglevels. If your console tab is not visible you can acivate it from the top menu called View.

Just tested this in MX 5.6.2 with the case described without issues. Are you sure that you set the column numbers correctly (the first column is 0). Did you set the type field to attribute (not the standard do not use) Also check the import action is this set to synchronize?

answered
0

It seems most likely to me that you are referencing the wrong sheet. Do you have any hidden sheets,
make sure you start counting your sheet nr as nr 1
start counting your column numbers at 0
(that is how excel stores the sheet nr).


If you enable the lognode: "ExcelXLSReader" to trace, you should be able to see the sheets, and values that are found by the module.
If you don't see anything or data different from what you are expecting you probably are referencing the wrong sheet, columns or rows as Erwin mentioned.

answered