Caching Warning: We are getting below the warning message when ever user logs into the application, in server log post the model upgrade to 4.8.3 version

0
WARNING - Caching: Cache: 5ee49c58-ec23-47a2-b03e-a6989aa6f803 has a maxElementsInMemory of 0. In Ehcache 2.0 this has been changed to mean a store with no capacity limit. Set it to 1 if you want no elements cached in memory
asked
2 answers
0

Have you configured the custom server setting called MxObjectCacheMaxEntriesLocalHeap? If so, remove that setting and any others related to caching. A number of fixes related to caching were done in Mendix 4.8.0 and higher that should make using these settings obsolete.

*Edit: If this doesn't help, I don't really know what could be the problem. Do you have any custom logging configuration that could override the Mendix default settings? Even though this is a warning, it's not really a problem and is usually surpressed by Mendix.

answered
0

Hi Vishnubholta,

We are also getting this error about Ehcache 2.0 and we like to know if you solved this issue yet? I can't provide more information about the subject, only that this MxObjectCacheMaxEntriesLocalHeap is not configured so it should be something else...

Thanks in advance for your response.

answered