Problem connecting to the remote debugger

0
Hi I am trying to connect using the remote debugger to an Appl that is running on a remote client server. This is the error msg I am getting: Any thoughts on how to solve this ? Does it have anything to do with the fact that we are running IE7? thanks Mendix.Modeler.MicroFlows.Debugger.DebuggerException: Failed to parse response text for start_session request. Response text: <!-- putting IE6-7 in quirks mode --> <!doctype html> <html> <head> <title>ING Alert Handling &amp; Fraud Management</title> <!-- keeping IE8-9 in standards mode --> <meta http-equiv="X-UA-Compatible" content="IE=edge;chrome=1" /> <meta http-equiv="expires" content="0" /> <meta http-equiv="pragma" content="no-cache" /> <link type="text/css" rel="stylesheet" href="mxclientsystem/mxui/ui/mxui.css" media="screen"/> <link type="text/css" rel="stylesheet" href="ui/theme-ing/layout.css" media="screen"/> <link type="text/css" rel="stylesheet" href="ui/theme-ing/custom.css" media="screen"/> <!--[if IE 6]> <link type="text/css" rel="stylesheet" href="ui/ie6/banner.css" media="screen"/> <![endif]--> <script type="text/javascript" src="mxclientsystem/dojo/dojo.js" djConfig=" rtlRedirect: 'index-rtl.html' "> </script> </head> <body class="tundra default ing"> <div dojoType="dijit.layout.BorderContainer" design="headline" gutters="false" id="mainbox" class="MxClient_mainContainer" > <div dojoType="dijit.layout.ContentPane" region="top" id="topPane" class="MxClient_topPane" > <div class="MxClient_headerPane"> <div class="MxClient_logoPane png"></div> </div> <div class="navigationPane_bg"> <div class="MxClient_navigationPane"> <div class="MxClient_loader" id="MxClient_loader"></div> <div dojoType="mxui.widget.Toolbar" id="MxClient_toolbar" class="MxClient_toolbar"></div> <div dojoType="mxui.widget.Navbar" id="MxClient_navbar" class="MxClient_navbar"></div> </div> </div> <div dojoType="mxui.widget.TitlePath" id="MxClient_titlepath" class="MxClient_titlepath"> </div> </div> <div dojoType="dijit.layout.BorderContainer" region="center" design="sidebar" liveSplitters="false" class="MxClient_contentContainer" > <div dojoType="mxui.widget.ScreenBuffer" region="center" id="contentPort" class="MxClient_contentPane" > </div> </div> <div dojoType="dijit.layout.ContentPane" region="bottom" class="MxClient_bottomPane" > <div class="MxClient_footerPane"> <div align="center">Powered by <a target="_blank" href="http://www.mendix.com">Mendix</a> Delivered by <a target="_blank" href="http://www.finaps.nl">Finaps</a></div> </div> </div> </div> <!--[if IE 6]> <div id="ie6banner" class="ie6banner" style="display:none"> <img src="ui/ie6/ie6banner.png" width="280" height="90" border="0" usemap="#ie6banner" /> <map name="ie6banner"> <area shape="rect" coords="35,34,75,74" href="http://www.mozilla-europe.org/" target="_blank" title="Mozilla Firefox" /> <area shape="rect" coords="82,34,122,74" href="http://www.google.com/chrome/" target="_blank" title="Google Chrome" /> <area shape="rect" coords="129,34,169,74" href="http://www.apple.com/safari/" target="_blank" title="Apple Safari" /> <area shape="rect" coords="176,34,216,74" href="http://www.microsoft.com/windows/internet-explorer/default.aspx" target="_blank" title="Microsoft Internet Explorer" /> </map> </div> <![endif]--> <script type="text/javascript" src="mxclientsystem/mxui/mxui.js"></script> </body> </html> ---> Newtonsoft.Json.JsonReaderException: Unexpected character encountered while parsing value: <. Line 1, position 1. at Newtonsoft.Json.JsonTextReader.ParseValue(Char currentChar) in d:\Development\Releases\Json\Working\Src\Newtonsoft.Json\JsonTextReader.cs:line 657 at Newtonsoft.Json.JsonTextReader.ReadInternal() in d:\Development\Releases\Json\Working\Src\Newtonsoft.Json\JsonTextReader.cs:line 400 at Newtonsoft.Json.JsonTextReader.Read() in d:\Development\Releases\Json\Working\Src\Newtonsoft.Json\JsonTextReader.cs:line 313 at Newtonsoft.Json.Linq.JObject.Load(JsonReader reader) in d:\Development\Releases\Json\Working\Src\Newtonsoft.Json\Linq\JObject.cs:line 257 at Newtonsoft.Json.Linq.JObject.Parse(String json) in d:\Development\Releases\Json\Working\Src\Newtonsoft.Json\Linq\JObject.cs:line 283 at Mendix.Modeler.MicroFlows.Debugger.DebuggerResponse..ctor(String requestActionName, String responseText) in c:\cygwin\home\autobuild\build\Mendix-4\modeler\Modeler\MicroFlows\Debugger\DebuggerResponse.cs:line 12 --- End of inner exception stack trace --- at Mendix.Modeler.MicroFlows.Debugger.DebuggerResponse..ctor(String requestActionName, String responseText) in c:\cygwin\home\autobuild\build\Mendix-4\modeler\Modeler\MicroFlows\Debugger\DebuggerResponse.cs:line 23 at Mendix.Modeler.MicroFlows.Debugger.DebuggerClient.PerformRequest(DebuggerRequest request, Int32 timeout) in c:\cygwin\home\autobuild\build\Mendix-4\modeler\Modeler\MicroFlows\Debugger\DebuggerClient.cs:line 166 at Mendix.Modeler.MicroFlows.Debugger.DebuggerClient.StartSession(IEnumerable1 breakpoints) in c:\cygwin\home\autobuild\build\Mendix-4\modeler\Modeler\MicroFlows\Debugger\DebuggerClient.cs:line 64 at Mendix.Modeler.MicroFlows.Debugger.DebuggerControl.<>c__DisplayClass2a.<StartDebugging>b__28(DebuggerClient c) in c:\cygwin\home\autobuild\build\Mendix-4\modeler\Modeler\MicroFlows\Debugger\DebuggerControl.cs:line 251 at Mendix.Modeler.MicroFlows.Debugger.DebuggerControl.<>c__DisplayClass101.<>cDisplayClass12.<clientdosync>bf() in c:\cygwin\home\autobuild\build\Mendix-4\modeler\Modeler\MicroFlows\Debugger\DebuggerControl.cs:line 99 at Mendix.Modeler.Utility.Progress.ProgressUtil.<>cDisplayClass4`1.<do>b3(ProgressInfo info) in c:\cygwin\home\autobuild\build\Mendix-4\modeler\Mendix.Modeler.Utility.Gui\Progress\ProgressUtil.cs:line 25 at Mendix.Modeler.Utility.Progress.Step.Run(ProgressInfo info) in c:\cygwin\home\autobuild\build\Mendix-4\modeler\Mendix.Modeler.Utility.Gui\Progress\Step.cs:line 22 at Mendix.Modeler.Utility.Progress.Process.worker_DoWork(Object sender, DoWorkEventArgs e) in c:\cygwin\home\autobuild\build\Mendix-4\modeler\Mendix.Modeler.Utility.Gui\Progress\Process.cs:line 91 at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e) at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
asked
1 answers
0

It seems you forget to include /debugger at the end of the URL to connect to.

see this blogpost for more examples / details

answered