Deep Link security

0
Hi, The deeplinks that I have without any restriction (Guests can execute them) don't present any problem. But I have one deeplink that requires authentication. It uses an object and an attribute of this object also to execute the microflow. When I click the link from my e-mail, the login page appears and I introduce my username and password but it redirects me directly to the application and the microflow is not executed. What is the problem with this? I also tried to use an anonymous access for this deeplink but it doesn't work and an error screen indicates me that the Guest user cannot see that object (something similar to the screenshots of the application). Any idea? UPDATE: Here you have the image of the error that I get when I just change the property "AllowGuests" to true. Anyway, I really need that just an authenticated user executes this. UPDATE 2: My default home configuration was already a microflow. It was modified when I started to use deeplinks and I don't have problems with anonymous user but the logged-in ones cannot execute any deeplink. Here you have an image of the microflow for my default Home page: In addition, I think it is important to specify that this default home page works just for the anonymous user because I specify an alternative (static form) home page per role (for all of them is the same, except for the temp or anonymous user). My after sign-in microflow is the following: Where 'Index' is the alternative home page for all the logged-in users.
asked
1 answers
2

Apparently, the guest/anonymous role in your application has no access to the object, or the object with value '7' does not exist. Did you check both conditions stated in the error message?

Note that to make the deeplinks work, you have to setup your after login navigation accordingly, as described in the documentation.

UPDATE

In addition, I think it is important to specify that this default home page works just for the anonymous user because I specify an alternative (static form) home page per role (for all of them is the same, except for the temp or anonymous user).

You need to do this for all the alternative homepages as well, since they override your default homepage setting. That explains why it is not working for your logged in users.

I never used the after sign-in Microflow, so I'm not sure what the impact of that flow is on the complete startup sequence.

As stated, the error you are getting for the guest users is probably related to your security rules.

answered