Datagrid2: Autonumber attribute erroneously sorted as string

0
I have a Datagrid2 which uses a microflow as data source. This microflow sorts the data by autonumber attribute “Checklist ID” before handing it over to the datagrid 2. The records are sorted as expected, i.e. in numerical sequence. Now when applying the Datagrid2 sort feature (e.g. to change from descending to ascending) the autonumber attribute is not sorted numerical, but as a string. This leads to sorting issues like depicted here:   Is this intended behavior? If not: how can I change this Datagrid2 behavior from string sort to numeric sort?
asked
1 answers
0

Bernd,

 

I tried to reproduce your problem, and I couldn’t. Anyway, can you try the following :

1). Change the column of your Autonumber Attribute to Custom content

 

Drag a text box in the row and make it dynamic

 

As value give it: parseInteger($currentObject/<YourAttributeName>)

 

Either you get an error because <YourAttributeName> is a number and it expects a String, or it works.

 

In case of Error: You found a bug (maybe upgrading to a higher version is an option. Also look into release notes to see if it is a known error)

 

 

Go Make It

answered