Deploy mendix to openshift error

0
It is OK to deploy the local environment in the form of docker, but it fails to deploy to the openshift environment Has anyone ever made such a mistake?   INFO:                                ##        .                          ## ## ##       ==                        ## ## ## ##      ===                    /""""""""""""""""\___/ ===               ~~~ {~~ ~~~~ ~~~ ~~~~ ~~ ~ /  ===- ~~~                    \______ o          __/                      \    \        __/                       \____\______/      __  __        _  _     _____             _     |  \/  |      | || |   |  __ \           | |     | \  / |_  __ | || |_  | |  | | ___   ___| | _____ _ __     | |\/| \ \/ / |__   _| | |  | |/ _ \ / __| |/ / _ \ '__|     | |  | |>  <     | |   | |__| | (_) | (__|   <  __/ |     |_|  |_/_/\_\    |_|   |_____/ \___/ \___|_|\_\___|_|                                 digitalecosystems@mendix.com      WARNING: DATABASE_ENDPOINT environment variable not found.Fallback to custom runtime variables https://github.com/mendix/cf-mendix-buildpack/#configuring-custom-runtime-settings INFO: Executing export_industrial_edge_config_variable... INFO: Adding uid to /etc/passwd INFO: Mendix Cloud Foundry Buildpack v4.28.4 [b337fc3] starting... WARNING: CF_INSTANCE_INDEX environment variable not found, assuming cluster leader responsibility... INFO: Unable to look up mendix runtime files because product version is yet unknown. ERROR: Starting application failed. Traceback (most recent call last):   File "/opt/mendix/buildpack/buildpack/start.py", line 137, in <module>     m2ee = runtime.setup(util.get_vcap_data())   File "/opt/mendix/buildpack/buildpack/core/runtime.py", line 659, in setup     "admin_pass": security.get_m2ee_password()   File "/opt/mendix/buildpack/lib/m2ee/core.py", line 27, in __init__     self.reload_config()   File "/opt/mendix/buildpack/lib/m2ee/core.py", line 39, in reload_config     config=self._initial_config["config"],   File "/opt/mendix/buildpack/lib/m2ee/config.py", line 96, in __init__     self._setup_classpath()   File "/opt/mendix/buildpack/lib/m2ee/config.py", line 125, in _setup_classpath     classpath.extend(self._setup_classpath_model())   File "/opt/mendix/buildpack/lib/m2ee/config.py", line 894, in _setup_classpath_model     if self.runtime_version < 5: TypeError: '<' not supported between instances of 'NoneType' and 'int'
asked
0 answers