Error while running my application

0
Hi, This is the error I'm encountering while running my application. I’m really not sure what to do. Can anyone please guide me through this? Thanks in Advance! PFB stack trace: [rtlauncher:container$] INFO Evictions for component 'project-userlib': Evicted C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\bcpkix-jdk15on-1.69.jar by C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\bcpkix-jdk15on-150.jar. Evicted C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\commons-io-2.6.jar by C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\commons-io-2.11.0.jar. Evicted C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\opencsv-4.1.jar by C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\opencsv-5.4.jar. Evicted C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\bcprov-jdk15on-1.69.jar by C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\bcprov-jdk15on-150.jar. Evicted C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\commons-io-2.8.0.jar by C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\commons-io-2.11.0.jar. Evicted C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\bcpg-jdk15on-1.69.jar by C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\bcpg-jdk15on-150.jar. Evicted C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\javax.mail-1.6.0.jar by C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\javax.mail-1.6.2.jar. Evicted C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\commons-lang3-3.5.jar by C:\Users\Prolim\Documents\Mendix\Test-main_2\deployment\model\lib\userlib\commons-lang3-3.11.jar. Exception in thread "main" java.lang.UnsupportedClassVersionError: system/UserActionsRegistrar has been compiled by a more recent version of the Java Runtime (class file version 62.0), this version of the Java Runtime only recognizes class file versions up to 55.0     at java.base/java.lang.ClassLoader.defineClass1(Native Method)     at java.base/java.lang.ClassLoader.defineClass(ClassLoader.java:1016)     at java.base/java.security.SecureClassLoader.defineClass(SecureClassLoader.java:174)     at java.base/java.net.URLClassLoader.defineClass(URLClassLoader.java:550)     at java.base/java.net.URLClassLoader$1.run(URLClassLoader.java:458)     at java.base/java.net.URLClassLoader$1.run(URLClassLoader.java:452)     at java.base/java.security.AccessController.doPrivileged(Native Method)     at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:451)     at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588)     at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)     at com.mendix.container.componentregistry.Component$.$anonfun$load$1(Component.scala:101)     at scala.util.Try$.apply(Try.scala:210)     at com.mendix.container.componentregistry.Component$.load(Component.scala:101)     at com.mendix.container.componentregistry.internal.ClassloaderComponentReader$.loadComponent(ClassloaderComponentReader.scala:61)     at com.mendix.container.componentregistry.internal.ClassloaderComponentReader$.$anonfun$parse$5(ClassloaderComponentReader.scala:50)     at scala.collection.immutable.List.flatMap(List.scala:293)     at com.mendix.container.componentregistry.internal.ClassloaderComponentReader$.$anonfun$parse$3(ClassloaderComponentReader.scala:48)     at scala.collection.immutable.List.flatMap(List.scala:293)     at com.mendix.container.componentregistry.internal.ClassloaderComponentReader$.$anonfun$parse$2(ClassloaderComponentReader.scala:47)     at scala.collection.immutable.List.flatMap(List.scala:293)     at com.mendix.container.componentregistry.internal.ClassloaderComponentReader$.parse(ClassloaderComponentReader.scala:46)     at com.mendix.container.componentregistry.internal.ClassloaderComponentReader$.readComponents(ClassloaderComponentReader.scala:31)     at com.mendix.container.componentregistry.internal.ClassloaderComponentReader$.$anonfun$read$3(ClassloaderComponentReader.scala:26)     at scala.collection.immutable.List.flatMap(List.scala:293)     at com.mendix.container.componentregistry.internal.ClassloaderComponentReader$.$anonfun$read$1(ClassloaderComponentReader.scala:26)     at scala.util.Either.map(Either.scala:382)     at com.mendix.container.componentregistry.internal.ClassloaderComponentReader$.read(ClassloaderComponentReader.scala:22)     at com.mendix.container.componentregistry.ComponentRegistry$.run(ComponentRegistry.scala:14)     at com.mendix.container.boot.Container$.doStart(Container.scala:114)     at com.mendix.container.boot.Container$.doStart(Container.scala:97)     at com.mendix.container.boot.Container$.$anonfun$startAndWaitForever$2(Container.scala:74)     at scala.util.Either.flatMap(Either.scala:352)     at com.mendix.container.boot.Container$.$anonfun$startAndWaitForever$1(Container.scala:73)     at com.mendix.container.boot.Container$.time(Container.scala:156)     at com.mendix.container.boot.Container$.startAndWaitForever(Container.scala:73)     at com.mendix.container.boot.Main$.$anonfun$new$2(Main.scala:15)     at scala.util.Either.flatMap(Either.scala:352)     at com.mendix.container.boot.Main$.delayedEndpoint$com$mendix$container$boot$Main$1(Main.scala:14)     at com.mendix.container.boot.Main$delayedInit$body.apply(Main.scala:11)     at scala.Function0.apply$mcV$sp(Function0.scala:39)     at scala.Function0.apply$mcV$sp$(Function0.scala:39)     at scala.runtime.AbstractFunction0.apply$mcV$sp(AbstractFunction0.scala:17)     at scala.App.$anonfun$main$1(App.scala:76)     at scala.App.$anonfun$main$1$adapted(App.scala:76)     at scala.collection.IterableOnceOps.foreach(IterableOnce.scala:563)     at scala.collection.IterableOnceOps.foreach$(IterableOnce.scala:561)     at scala.collection.AbstractIterable.foreach(Iterable.scala:926)     at scala.App.main(App.scala:76)     at scala.App.main$(App.scala:74)     at com.mendix.container.boot.Main$.main(Main.scala:11)     at com.mendix.container.boot.Main.main(Main.scala)  
asked
1 answers
1

Have you edited or viewed any of the Java modules in Eclipse? You have a .jar file that is compiled for a later version of Java than Mendix supports. This can happen if you open the Mendix project in Eclipse, and Eclipse has automatic compilation turned on. If this is the case you can either turn off the automatic compilation or set it to build with Java 11. Personally, I turn off compilation and let Mendix compile the Java Actions when it builds the app.

answered